What are the system requirements for Whiteboard App for Android?

You need Android 4.4 or above to run the Whiteboard App for Android.

Have more questions? Submit a request

Comments

Powered by Zendesk